What to do when a reply has broken flatboard

dagrit
What to do when a reply has broken flatboard
dagrit@fd995149 Wednesday 5th July 2023, 10:40:27

I had flatboard running for a few weeks to test and the forum got up a little but now there is a message:

Warning: Undefined array key "reply" in /home/[forum url]index.php on line 95

Fatal error: Uncaught TypeError: count(): Argument #1 ($value) must be of type Countable|array, null given in /home/[forum url]index.php:95 Stack trace: #0 {main} thrown in /home/[forum url]index.php on line 95

This basically breaks everything, I can look into the php file but have no idea where the errors are coming from because this just worked on install. I have the feeling a reply from a bot/hack caused this. Not a very good tryout...

Reply 1
SurveyBuilder-Admin
SurveyBuilder-Admin  Wednesday 5th July 2023, 15:23:06

Good news, there is no bot, it’s just missing an array key value of “reply” represents this below
[“reply”=>[]]

So you may want to delete and reinstall flatboard, but backup your data first before removing. This means that the reply’s are not being sent correctly as an array or JSON file cannot be converted to an array. Hope that helps.

Last modified by SurveyBuilder-Admin on Wednesday 5th July 2023, 15:25:00
Software engineer, creates plugins for Flatboard, checks source codes, and answers any software errors questions and contributes on the GitHub page as well

Suggested Topics
started
245.3K 0
SurveyBuilder-Admin
SurveyBuilder-Admin started Image Viewer - Release
Resources
2.1K 1
Want to read more? Browse all categories or view latest topics.